Live Timing

Incident Report for Supercars

Resolved

This incident has been resolved.
Posted Sep 13, 2025 - 17:31 AEST

Update

We are continuing to monitor for any further issues.
Posted Sep 13, 2025 - 17:31 AEST

Update

We are continuing to monitor for any further issues.
Posted Sep 13, 2025 - 16:01 AEST

Monitoring

A fix for enhanced live timing has been implemented and we are now monitoring.
Posted Sep 13, 2025 - 15:53 AEST

Investigating

We are currently investigating an issue with enhanced live timing, users are encouraged to view live timing in classic mode or for MySupercars+ members through the Live Insights dashboard.
Posted Sep 12, 2025 - 14:38 AEST
This incident affected: Live Timing.